summaryrefslogtreecommitdiff
path: root/elpa/irony-20220110.849/server/CMakeLists.txt
diff options
context:
space:
mode:
authormattkae <mattkae@protonmail.com>2022-05-11 09:23:58 -0400
committermattkae <mattkae@protonmail.com>2022-05-11 09:23:58 -0400
commit3f4a0d5370ae6c34afe180df96add3b8522f4af1 (patch)
treeae901409e02bde8ee278475f8cf6818f8f680a60 /elpa/irony-20220110.849/server/CMakeLists.txt
initial commit
Diffstat (limited to 'elpa/irony-20220110.849/server/CMakeLists.txt')
-rw-r--r--elpa/irony-20220110.849/server/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/elpa/irony-20220110.849/server/CMakeLists.txt b/elpa/irony-20220110.849/server/CMakeLists.txt
new file mode 100644
index 0000000..21f9c9f
--- /dev/null
+++ b/elpa/irony-20220110.849/server/CMakeLists.txt
@@ -0,0 +1,33 @@
+cmake_minimum_required(VERSION 3.0.2)
+
+project(IronyMode)
+
+set(CMAKE_MODULE_PATH
+ ${PROJECT_SOURCE_DIR}/cmake
+ ${PROJECT_SOURCE_DIR}/cmake/modules
+ ${CMAKE_MODULE_PATH})
+
+include(CTest)
+include(GNUInstallDirs)
+
+# Starting from CMake >= 3.1, if a specific standard is required,
+# it can be set from the command line with:
+# cmake -DCMAKE_CXX_STANDARD=[11|14|17]
+function(irony_target_set_cxx_standard target)
+ set(cxx_standard 11)
+ if (CMAKE_VERSION VERSION_LESS "3.1")
+ if (CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
+ target_compile_options(${target} PRIVATE -std=c++${cxx_standard})
+ endif()
+ elseif (CMAKE_VERSION VERSION_LESS "3.8")
+ set_property(TARGET ${target} PROPERTY CXX_STANDARD ${cxx_standard})
+ else()
+ target_compile_features(${target} PUBLIC cxx_std_${cxx_standard})
+ endif()
+endfunction()
+
+add_subdirectory(src)
+
+if (BUILD_TESTING)
+ add_subdirectory(test)
+endif()