summaryrefslogtreecommitdiff
path: root/elpa/irony-20220110.849/server/CMakeLists.txt
diff options
context:
space:
mode:
authormattkae <mattkae@protonmail.com>2022-06-07 08:23:47 -0400
committermattkae <mattkae@protonmail.com>2022-06-07 08:23:47 -0400
commitbd18a38c2898548a3664a9ddab9f79c84f2caf4a (patch)
tree95b9933376770381bd8859782ae763be81c2d72b /elpa/irony-20220110.849/server/CMakeLists.txt
parentb07628dddf418d4f47b858e6c35fd3520fbaeed2 (diff)
parentef160dea332af4b4fe5e2717b962936c67e5fe9e (diff)
Merge conflict
Diffstat (limited to 'elpa/irony-20220110.849/server/CMakeLists.txt')
-rw-r--r--elpa/irony-20220110.849/server/CMakeLists.txt33
1 files changed, 0 insertions, 33 deletions
diff --git a/elpa/irony-20220110.849/server/CMakeLists.txt b/elpa/irony-20220110.849/server/CMakeLists.txt
deleted file mode 100644
index 21f9c9f..0000000
--- a/elpa/irony-20220110.849/server/CMakeLists.txt
+++ /dev/null
@@ -1,33 +0,0 @@
-cmake_minimum_required(VERSION 3.0.2)
-
-project(IronyMode)
-
-set(CMAKE_MODULE_PATH
- ${PROJECT_SOURCE_DIR}/cmake
- ${PROJECT_SOURCE_DIR}/cmake/modules
- ${CMAKE_MODULE_PATH})
-
-include(CTest)
-include(GNUInstallDirs)
-
-# Starting from CMake >= 3.1, if a specific standard is required,
-# it can be set from the command line with:
-# cmake -DCMAKE_CXX_STANDARD=[11|14|17]
-function(irony_target_set_cxx_standard target)
- set(cxx_standard 11)
- if (CMAKE_VERSION VERSION_LESS "3.1")
- if (CMAKE_CXX_COMPILER_ID MATCHES "GNU|Clang")
- target_compile_options(${target} PRIVATE -std=c++${cxx_standard})
- endif()
- elseif (CMAKE_VERSION VERSION_LESS "3.8")
- set_property(TARGET ${target} PROPERTY CXX_STANDARD ${cxx_standard})
- else()
- target_compile_features(${target} PUBLIC cxx_std_${cxx_standard})
- endif()
-endfunction()
-
-add_subdirectory(src)
-
-if (BUILD_TESTING)
- add_subdirectory(test)
-endif()