summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormattkae <mattkae@protonmail.com>2023-06-22 13:48:11 -0400
committermattkae <mattkae@protonmail.com>2023-06-22 13:48:11 -0400
commit29e03ef74a814cb31a0ae53192e25cc75b638256 (patch)
treee992398b4fba704859653f615ba40aab6e4eee94 /CMakeLists.txt
parentd53f2e7107cf63669b705c3abf08c129eeb0315e (diff)
Handling less than signs in plain text
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a65ed8b..56e8ff8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,12 @@ set(CMAKE_CXX_STANDARD_REQUIRED ON)
add_executable(html_parser src/main.cpp src/html_token.cpp src/tokenizer.cpp)
+if(MSVC)
+ target_compile_options(html_parser PRIVATE /W4 /WX)
+else()
+ target_compile_options(html_parser PRIVATE -Wall -Wextra -Wpedantic -Wswitch-enum)
+endif()
+
target_link_libraries(html_parser -lmatte)
install(TARGETS html_parser