summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a65ed8b..56e8ff8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,12 @@ set(CMAKE_CXX_STANDARD_REQUIRED ON)
add_executable(html_parser src/main.cpp src/html_token.cpp src/tokenizer.cpp)
+if(MSVC)
+ target_compile_options(html_parser PRIVATE /W4 /WX)
+else()
+ target_compile_options(html_parser PRIVATE -Wall -Wextra -Wpedantic -Wswitch-enum)
+endif()
+
target_link_libraries(html_parser -lmatte)
install(TARGETS html_parser